Warnings upgrading from 15.3.2 to 15.4.2

Hello,

We have been upgrading a Gitlab (omnibus) instance from v15.3.2 to v15.4.2, and we got the following warnings during reconfigure step :

> [2022-10-03T09:42:24+02:00] WARN: Connecting to GitLab to generate new app_id and app_secret for GitLab Pages.
> [2022-10-03T09:42:53+02:00] WARN: Something went wrong while executing gitlab-rails runner command to get or create the app ID and secret.
> [2022-10-03T09:42:55+02:00] WARN: Connecting to GitLab to generate new app_id and app_secret for GitLab Grafana.
> [2022-10-03T09:43:23+02:00] WARN: Something went wrong while trying to update gitlab-secrets.json. Check the file permissions and try reconfiguring again.

Those messages are emitted each time we perform a reconfigure, as Gitlab fails to generate its new app_ids and app_secrets.

Digging into code, it seems that module AuthorizeHelper gets an empty runner_cmd here :

even if create_or_find_authorization() seems to be called with valid (non empty, at least) arguments.

Any idea what could be wrong in our config ?

Best regards,

Ganael.

Good day,

i have the same problem with 15.4.1 and 15.4.2.

Best regards,

Bjoern

Hi,

Thanks for your feedback.

Does someone know a way to fix those warnings ?

Hello,

The problem still arises when upgrading to 15.5.2. Any hint ?

Hi,
but someone know a workaround to fix the issue related to it?
In my case Mattermost SSO stop to authenticate with gitlab username/password. I think becouse of App Mattermost need to be connected to gitlab again. Also regenerating App-ID and Secret-ID the problem remains.

Thanks