Webhooks not possible to own server


I use Omnibus GitLab and Plesk 17.
Long time ago I used webhooks, to deploy my code automatically to my vhost.

It worked well. Now I have not used it for a long time.
When I wanted to use a webhook again today, I always got an http error 500. I experimented a lot, it did not work for me.

Then I used the address of another server, and it worked fine.
Now I have tried it with the gitlab server of my friend, he has the same issue.

He can create a webhook to my server. But not a webhook to his own server.
I can create a webhook to his server, but not to my own server.

It looks as if the request will not be executed, because Gitlab itself returns error 500.

With the remote server, it makes a reaquest and the status is shown as flash-alert.

Maybe somebody can check if it’s the same for others.

Thank you!

p.s.: Please excuse my bad english, I only want to help :smiley:

Same issue here…

1 Like

If you’re using 10.6, see the solution here: Jenkins CI 500 error

1 Like

Thank you. Works fine now. :slight_smile: