Weird behavior. Login not working. Perhaps hacked account? Or just glitch? I had 2FA

I tried pushing an update to my repo on gitlab but it wouln’t get past the login.

I go to gitlab and try to login. Doesn’t work.

I also try the github Oauth login which is how I created the account originally. Doesn’t work. It times out. If I try it in an incognito window I get an error response from github.

I try to reset the password. When I go to my email to check for the password reset link, I see there is an email saying that 7 minutes ago, someone logged into my account from an IP that google tells me is in California. I’m in Texas.

I reset the password. Try to login with the new password. Doesn’t work. I try resetting it again. Still doesn’t work. I reset the password a third time, still doesn’t work. I get emails telling me the password has been changed but the new nor old passwords work.

Is this some weird Gitlab glitch or have I been hacked?

Also I have 2FA enabled. So really not sure what’s going on with that

nevermind. Issue was fixed here: Account has been blocked

I forgot to reconfirm my email address

1 Like

Glad that you found the solution, @jcklpe. Thanks for coming back to share it!