What version of perl is supported for gitlab 16.0.7

Hi Team,

We are trying to install gitlab 16.0.7 version. But it is failing with perl dependecy
We already have perl installed with this version v5.26.3

Can you please let us know which perl version supports gitlab version 16?

rpm -Uvh gitlab-ce-16.0.7-ce.0.el8.x86_64.rpm
warning: gitlab-ce-16.0.7-ce.0.el8.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID f27eab47: NOKEY
error: Failed dependencies:
perl is needed by gitlab-ce-16.0.7-ce.0.el8.x86_64

Thank you,
Mridula U

AFAIK the rpm CLI cannot resolve dependencies automatically. You can use dnf/yum instead to install a local package file, and try if that resolves the dependency error.

dnf install gitlab-ce-16.0.7-ce.0.el8.x86_64.rpm

Please find the attached image. I am getting error while executing dnf command

The problem is your system is not registered to a subscription with Red Hat so it cannot install the required dependencies. Register your machine with Red Hat with the subscription that you purchased. You do that using subscription-manager register

The error message above clearly shows that.

2 Likes

Hi @iwalker

I was able to successfully install the 16.0.7 version. But when I tried to access UI in browser,i giving 502 error
and in the logs we can see below error:

2023/07/17 13:40:19 [crit] 2363423#0: *5 connect() to unix:/var/opt/gitlab/gitlab-workhorse/sockets/socket failed (2: No such file or directory) while connecting to upstream, client: 10.10.xx.xx, server: 10.10.xx.xx, request: “GET /gitlab HTTP/1.1”, upstream: “http://unix:/var/opt/gitlab/gitlab-workhorse/sockets/socket:/gitlab”, host: “10.10.xx.xx”

thereis no socket file inside the sockets folder…How can we fix this issue?

Thank you,
Mridula U

Sounds like you have a configuration problem. You cannot have http://unix:/ in your configuration, either it is a socket so unix:// or it is via IP, so http:// - as it mentions upstream, does that mean you have configured nginx proxy somewhere for your install? If so then you need to check it because it is incorrectly configured. Or perhaps you made changes in /etc/gitlab/gitlab.rb and so you need to check this also.

Otherwise, you are going to have to explain in more detail you configuration so people can help.

Don’t post images of text!

Hi @iwalker

in rhel 8.8
I ran “dnf install gitlab-ce” command ,required packages and gitlab is installed without error
I havent changed anything in gitlab.rb file except external_url and then ran the “gitlab-ctl reconfigure” command and tried to access UI ,but its throwing error.

Same steps I repeated in rhel 7.9 …it is has no errors

Can you try this to rule out selinux:

setenforce 0
gitlab-ctl reconfigure
gitlab-ctl restart

now try to access your Gitlab, does it work? If yes, then we know that selinux is messing around somewhere. If no, then there is something else amiss.

Running:

getenforce

after using the above commands should show permissive. If not, try again until it does say this. This is only temporary so we can find out where the problem is. A reboot will switch it back to enforcing.

Hi @iwalker

I executed the above set commands and tried to access UI, but still same error
And getenforce command is giving “permissive” as output

Still throwing 502 error…How to fix this issue?

Thank you,
Mridula U

Please provide results from:

gitlab-ctl status

copy and paste the text, please do not post screenshot. Also check all your logs under /var/log/gitlab for anything that potentially could be due to this, for example nginx logs. And post the logs that might look problematic.

A basic install should work perfectly fine providing that you followed the official Gitlab installation instructions. So the fact you are getting this, suggests it has been inconfigured correctly - otherwise there is no simple explanation or resolution to it.

Hi @iwalker

output of gitlab-ctl status
[root@EFASSandbox8 gitlab-workhorse 05:34 PM]# gitlab-ctl status
run: alertmanager: (pid 3340377) 0s; run: log: (pid 2364769) 22123s
run: gitaly: (pid 3340176) 4s; run: log: (pid 2361849) 22402s
run: gitlab-exporter: (pid 3340376) 0s; run: log: (pid 2363983) 22151s
run: gitlab-kas: (pid 3340301) 1s; run: log: (pid 2362183) 22370s
down: gitlab-workhorse: 0s, normally up, want up; run: log: (pid 2363340) 22186s
run: logrotate: (pid 3308608) 717s; run: log: (pid 2361749) 22422s
run: nginx: (pid 2990623) 7917s; run: log: (pid 2363441) 22180s
down: node-exporter: 0s, normally up, want up; run: log: (pid 2363562) 22173s
down: postgres-exporter: 0s, normally up, want up; run: log: (pid 2365176) 22114s
run: postgresql: (pid 2990921) 7911s; run: log: (pid 2361986) 22385s
down: prometheus: 1s, normally up, want up; run: log: (pid 2364396) 22135s
run: puma: (pid 2991017) 7909s; run: log: (pid 2363190) 22199s
run: redis: (pid 2991022) 7909s; run: log: (pid 2361788) 22412s
down: redis-exporter: 1s, normally up, want up; run: log: (pid 2364073) 22148s
run: sidekiq: (pid 2991338) 7902s; run: log: (pid 2363256) 22193s
[root@EFASSandbox8 gitlab-workhorse 07:45 PM]#

The workhorse service is not running, which explains the missing socket error.

Suggest continuing the analysis with inspecting the logs to learn why workhorse is not running. Log system | GitLab

Could be a performance or (SELinux) permission problem, since other services are not started either.