Why does an attempt to download a project archive from GitLab fail with a network error?

My GitLab is deployed in a docker container. I inherited it. Yesterday I from “Intellij IDEA” tried to clone one of the projects and received an error message:

RPC failed; curl 56 GnuTLS recv error (-9): A TLS packet with unexpected length was received. The remote end hung up unexpectedly early EOF index-pack failed

Then I tried to download the archive with the project and this also ended with a browser error message about the network error.

Repeated restart of the container with GitLab did not give anything.

Where to dig to solve the problem?

In addition to the initial post: a link to the terminal output with the “git clone …” command.


is there any sorts of HTTP proxy or packet filter/optimizer for TLS in place between you and the host?

I would dig into tcpdump, and also the container transport since you’ve mentioned that.


The solution to the problem lay in the intermediate network node. Out of disk space, which led to the interruption of the stream.

1 Like