X Your pipeline has failed. What pipeline? All I did was create a repo

Hello

I have no idea why this error happened. I just initialized and pushed to a new repo. I have created several repos that are identical. No errors. This error comes from some process using heroku and docker but my project is a simple git repo for a static site. No heroku or docker. The error report is below. Any suggestions to understand why this happened and stop this kind of error? Thank You!

Running with gitlab-runner 11.7.0-rc1 (6e20bd76)
on docker-auto-scale fa6cab46
Using Docker executor with image docker:stable-git …
Starting service docker:stable-dind …
Pulling docker image docker:stable-dind …
Using docker image sha256:067814781fbba30c17a86aa6159516660b6c210485ac9ac346d5101d6e4b70f0 for docker:stable-dind …
Waiting for services to be up and running…
Pulling docker image docker:stable-git …
Using docker image sha256:67fc6354da7f27de9f636d3b7fe118309fa269f60341a9b3783f5ca596741b24 for docker:stable-git …
Running on runner-fa6cab46-project-10545855-concurrent-0 via runner-fa6cab46-srm-1548547582-f0e73bfa…
Cloning repository…
Cloning into ‘/builds/ubiquity/lucid_content’…
Checking out 827eb5d9 as master…
Skipping Git submodules setup
# Auto DevOps variables and functions # collapsed multi-line command setup_docker
$ build
Logging to GitLab Container Registry with CI credentials…
WARNING! Using --password via the CLI is insecure. Use --password-stdin.
WARNING! Your password will be stored unencrypted in /root/.docker/config.json.
Configure a credential helper to remove this warning. See

Login Succeeded

Building Heroku-based application using gliderlabs/herokuish docker image…
Unable to find image ‘gliderlabs/herokuish:latest’ locally
latest: Pulling from gliderlabs/herokuish
7b8b6451c85f: Pulling fs layer
ab4d1096d9ba: Pulling fs layer
e6797d1788ac: Pulling fs layer
e25c5c290bde: Pulling fs layer
be673c6b0fbe: Pulling fs layer
fb700a7055ec: Pulling fs layer
b0e90c333af6: Pulling fs layer
ee5f8035a2b8: Pulling fs layer
b97daff2207e: Pulling fs layer
4368ab0e3495: Pulling fs layer
714cf4a5388c: Pulling fs layer
2d4089722b1c: Pulling fs layer
8c1392188cab: Pulling fs layer
e25c5c290bde: Waiting
be673c6b0fbe: Waiting
fb700a7055ec: Waiting
b0e90c333af6: Waiting
ee5f8035a2b8: Waiting
b97daff2207e: Waiting
4368ab0e3495: Waiting
714cf4a5388c: Waiting
2d4089722b1c: Waiting
8c1392188cab: Waiting
e6797d1788ac: Verifying Checksum
e6797d1788ac: Download complete
ab4d1096d9ba: Verifying Checksum
ab4d1096d9ba: Download complete
e25c5c290bde: Verifying Checksum
e25c5c290bde: Download complete
be673c6b0fbe: Verifying Checksum
be673c6b0fbe: Download complete
7b8b6451c85f: Verifying Checksum
7b8b6451c85f: Download complete
b0e90c333af6: Verifying Checksum
b0e90c333af6: Download complete
ee5f8035a2b8: Verifying Checksum
ee5f8035a2b8: Download complete
fb700a7055ec: Verifying Checksum
fb700a7055ec: Download complete
4368ab0e3495: Verifying Checksum
4368ab0e3495: Download complete
714cf4a5388c: Verifying Checksum
714cf4a5388c: Download complete
2d4089722b1c: Verifying Checksum
2d4089722b1c: Download complete
8c1392188cab: Verifying Checksum
8c1392188cab: Download complete
b97daff2207e: Verifying Checksum
b97daff2207e: Download complete
7b8b6451c85f: Pull complete
ab4d1096d9ba: Pull complete
e6797d1788ac: Pull complete
e25c5c290bde: Pull complete
be673c6b0fbe: Pull complete
fb700a7055ec: Pull complete
b0e90c333af6: Pull complete
ee5f8035a2b8: Pull complete
b97daff2207e: Pull complete
4368ab0e3495: Pull complete
714cf4a5388c: Pull complete
2d4089722b1c: Pull complete
8c1392188cab: Pull complete
Digest: sha256:29649dd4f3db4d234394cf56f0fc0c654fc3ee7e411988a17b09389032bacf5a
Status: Downloaded newer image for gliderlabs/herokuish:latest
-----> Unable to select a buildpack
ERROR: Job failed: exit code 1

I have the same problem as you do. The option for auto devops was already unchecked when creating the repo, I tried also checking/unchecking, same result.

I end up having a NOOP pipeline for my project.

Hopefully you already figured it out, if not or someone lese has the same problem, I added a .gitlab-ci.yml that looks like this

noop:
  script: echo NOOP

Far from ideal but at least now everything is green until I have a real pipeline.

ThanksI will try it out