Yum install gitlab-ee gives me version 13.6.4 instead of 13.7.x on Amazon Linux 2

 yum repolist
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
repo id                                                                                                             repo name                                                                                                               status
amzn2-core/2/x86_64                                                                                                 Amazon Linux 2 core repository                                                                                          23,016
amzn2extra-docker/2/x86_64                                                                                          Amazon Extras repo for docker                                                                                               36
gitlab_gitlab-ee/x86_64                                                                                             gitlab_gitlab-ee                                                                                                           645
gitlab_gitlab-ee-source                                                                                             gitlab_gitlab-ee-source                                                                                                      0
repolist: 23,697

and if I list the package versions for gitlab-ee

yum --showduplicates list gitlab-ee|grep 13.7
gitlab-ee.x86_64             8.13.7-ee.0.el6                   gitlab_gitlab-ee

So what am I doing wrong, is there a new yum repo or something?

Hi, it looks like the problem is you have a version of Linux based on RHEL6 - which means 13.7.x is not available. RHEL6, CentOS6 or other versions based on EL6 are no longer supported, this ended in November 2020 so there will be no longer system updates, etc or people providing packages for unsupported versions of Linux. Maybe Amazon will provide their own updates for their Linux version but unlikely. Therefore the latest of gitlab for you on EL6 is 13.6.4.

I suggest moving to a newer Linux release, Debian 10, Ubuntu 18.04 or even better 20.04. If you prefer an RPM distribution, then EL7 will be supported for a few more years yet, or EL8 even better. However, please do not choose CentOS since the project is dead - CentOS Stream is what replaced it and it is no longer the same as what CentOS used to be. It can effectively be categorised as a test/beta version of Linux (before the technology/packages are available in RHEL) and no longer stable like it used to be.

I think Amazon Linux 2 tries to be compatible with EL7:

rpm -E %{rhel}

but I see that curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.rpm.sh | sudo bash created /etc/yum.repos.d/gitlab_gitlab-ee.repo with


I can see in their script.rpm.sh that they explicitly set dist=6 for Amazon Linux but I don’t think that is accurate anymore.

I’ll try to install gitlab in a new EC2 instance using the EL7 rpms and see if they work.

Seems that using baseurl=https://packages.gitlab.com/gitlab/gitlab-ee/el/7/$basearch work.

I was able to upgrade to 13.7.2 and seems to be working.

1 Like

Also found Amazon Linux 2 is treated as el6 in script.rpm.sh (#5902) · Issues · GitLab.org / omnibus-gitlab · GitLab

Yep, the install script will attempt to get the information - potentially using lsb_release, so if they have ver=6 then it will have an effect on it. But glad the EL7 ones worked. Gitlab is pretty much self-contained when it comes to all of it’s dependencies especially when using omnibus packages - it doesn’t rely too much on the OS packages for anything. So as it installed and upgraded fine you should in theory be OK stability wise. Had gitlab required any OS dependencies it may have become tricky at this point.

Glad it all worked out.