2FA authentication error when 2FA is not enabled

Hi guys, one of my users got a strange error on one of repositories:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.5.2:prepare (default-cli) on project project1: Unable to commit files
[ERROR] Provider message:
[ERROR] The git-push command failed.
[ERROR] Command output:
[ERROR] remote: HTTP Basic: Access denied. The provided password or token is incorrect or your account has 2FA enabled and you must use a personal access token instead of a password. See https://my.domain.com/help/topics/git/troubleshooting_git#error-on-git-fetch-http-basic-access-denied
[ERROR] fatal: Authentication failed for ‘http://my.domain.com/group/project1.git/

Hi runs it from Ubuntu, tried to switch to another machine, it worked at first but than the error reappeared. No setting were changed. Other projects work fine. No two-factor authentication is enabled.

Any suggestions how to fix that?

Hi,

Perhaps the problem here is not 2FA, but rather what it says before it:

1 Like