404 on gitlab homepage after upgrading Gitlab-ce on ubuntu

Hi,
over the weekend I tried to upgrade a very old and negleted gitlab server on ubuntu, starting at a V10 installation. I followed Upgrading GitLab | GitLab instructions as much as I could through all the major releases and since V12 I lost access to the homepage on g{“content_type”:“text/html; charset=utf-8”,“correlation_id”:“01FYMPA9TD3PK62A3GWYMQJMZJ”,“duration_ms”:8,“host”:“db.qatsar.com”,“level”:“info”,“method”:“GET”,“msg”:“access”,“proto”:“HTTP/1.1”,“referrer”:"",“remote_addr”:“127.0.0.1:0”,“remote_ip”:“127.0.0.1”,“route”:"",“status”:404,“system”:“http”,“time”:“2022-03-21T11:14:13+13:00”,“ttfb_ms”:7,“uri”:"/",“user_agent”:“Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.74 Safari/537.36”,“written_bytes”:3108}
itlab’s nginx - it returns 404. As far as I understand this is redirected though socket to workhorse. I find in workhorses log file lines like
GetGeoProxyURL: Received HTTP status code: 404
repeated, and a request to ‘/’ triggers this record:

I cannot identify from this log what is wrong or missing, any suggestions?

Hi @SchlauFuchs
it would help if you could describe your steps during the upgrade process, so we can see if something was missed.
Otherwise, I would look into gitlab-rake logs if there isn’t any clue. You can also run gitlab-ctl status to see if all services are running.
The most common cases when upgrading from that old version are not updated OS and DB failures, because GitLab switched from MySQL to Postgress and you have to wait for the migration to complete, before proceeding with the upgrade further.

Hi,

I think I sorted it out now. For some reason, in the glitlab.rb file the port where gitlab-auth is running was wrong - after adjusting it it worked again. How it got wrong, I do not understand.

1 Like