Assets not shown after upgrade to 13.10.4

I have tried to upgrade my system from 13.10.2 to 13.10.4 using omnibus. Upgrade itself went fine and also did reconfigure. Sadly after the upgrade no assets (logos, Icons etc) are shown anymore.

I have done a similar upgrade on another machine without issues, but the one where it fails has /var/gitlab/git-data mounted via NFS. Not sure if that could have an impact.

Not sure, but I think you should look at migrating away from NFS, since it won’t be supported anymore. Documentation recommends Gitaly. All my upgrades have also worked without issues, but then I don’t use NFS.

https://docs.gitlab.com/ee/administration/nfs.html

In case the Redis cache is the problem you can do this:

gitlab-ctl restart redis

I had to do this recently, as after the upgrade it said an older version was running than the one installed, but it can also help to clear cache issues, if things aren’t rendering properly. Otherwise, it will require digging through the logs to search for errors. You can find them under /var/log/gitlab.

Hi.

Restarting redis did not help. This is the error message displayed in the browser:

For what I can look in the logs?

Greetings
Lioh

Hi again.

actually /opt/gitlab/embedded/service/gitlab-rails/public/assets/webpack does not even contain this runtime script:

-rw-r--r-- 1 root root 6557 Apr 27 18:50 runtime.3086b837.bundle.js
-rw-r--r-- 1 root root 3241 Apr 27 18:50 runtime.3086b837.bundle.js.gz
-rw-r--r-- 1 root root 6821 Apr 27 18:50 runtime.3086b837.bundle.js.map.gz

Creating relevant symlinks seems to help:

lrwxrwxrwx 1 root root   26 Apr 30 11:46 runtime.ff752e23.bundle.js -> runtime.3086b837.bundle.js
lrwxrwxrwx 1 root root   29 Apr 30 11:46 runtime.ff752e23.bundle.js.gz -> runtime.3086b837.bundle.js.gz
lrwxrwxrwx 1 root root   33 Apr 30 11:46 runtime.ff752e23.bundle.js.map.gz -> runtime.3086b837.bundle.js.map.gz

But could this really be the solution?

Greetings
Lioh

Latest version is 13.11.2, maybe upgrade to the latest, perhaps there are already fixes for it and thus not requiring the symlinks.

I don’t have these errors, and I’m running 13.11.2, but then I don’t use NFS which as mentioned will not be supported in the future.

Ok, I am going to try to upgrade to the latest version. Concerning NFS I am not really sure if this is related to the issue as /opt/gitlab resides on localstorage.