Autodevops not respecting CI_APPLICATION_TAG variable

Gitlab version: 11.3.3 (af2e5ea)
Gitlab runnner version: 11.3.1 (0aa5179e)

According to the following:



I should be able to override the application tag for images pushed to registry with CI_APPLICATION_TAG being defined in variables, but it doesn’t seem to work…

Successfully built da8b43bd1531
Successfully tagged registry.example.com/docker/cloudflared/master:e3acb237d6bab5d4fac6e5b3a69ebefd1c178652
Pushing to GitLab Container Registry...
The push refers to repository [registry.example.com/docker/cloudflared/master]

I’ve tried manually adding these variables (CI_APPLICATION_REPOSITORY and CI_APPLICATION_TAG) at build time, but i still get both the sha instead of tag (amd64) and the wrong repo (/cloudflared/master, instead of cloudflared)

Hi,

Perhaps I’m reading this wrong, but none of these merge requests were ever merged, thus I wouldn’t expect this functionality to be available. Or am I missing something?

hey thanks for the reply. I thought that to, but then i saw

in MR152, but yeah you’re right lookign back at !50, seems it’s still open, thus not implemented yet :frowning:

Thanks for clarifying that, I was going back and forth between all 3 trying to see if they were implemented yet and the “Closes” threw me off.

No worries. Ok, it seems we’re on the same page now. I thought I was missing something.

Indeed, that issue was never closed. Also, notice that the project you are looking at (https://gitlab.com/gitlab-org/gitlab-ci-yml) is no longer active. Its home page shows this deprecation notice:

This project has been deprecated and the templates have been moved to https://gitlab.com/gitlab-org/gitlab-ce/tree/master/lib/gitlab/ci/templates