Backup stopped working

Hello GitLab community,

My setup:

  • CentOS 7 (running in a VM)
  • Omnibus GitLab CE 10.4.0 128ef10 (installed via yum)

When creating a backup of GitLab, I normally went to the gitlab directory and used the command:

bundle exec rake gitlab:backup:create RAILS_ENV=production

which worked just fine. However, I tried this today and, for reasons unknown, the system told me that the command bundle could not be found. So I asked Google for help. Some articles in the web mentioned to install Ruby and Bundler anew, which I found odd, since Omnibus GitLab came with its own version of both (and it worked before). Nevertheless I did it, and when running above command, I now get the message:

Could not locate Gemfile or .bundle/ directory

This happens with both, Ruby 2.4.2, as well as Ruby 2.3.6, even if I provide the path to bundle within the above mentioned backup command. Now, there are suggestions out there, that I have to copy the Gemfile (I suppose this means bundle?) to a specific location, but I do not know which location. There are conflicting or blurry details. So, I am stuck.

I am not quite sure, this fiddling around with a Ruby version, outside of Omnibus GitLab, is the right solution in the first place. It just feels wrong, but I am out of ideas.

Can anyone help me please?

Bundler version 1.16.1 (2017-12-21 commit 0034ef341)

gitlab-rake gitlab:backup:create

Did the trick.

Don’t know whether something changed during versions, or I just remembered incorrectly.