On Ubuntu 16.04, I was running gitlab-ee(without license) 11.6.3, today i wanted to upgrade it, i simply did “apt-get upgrade” but it said the current version is 12… and before that i need to install 11.11.
I got .dpkg file to install 11.11 then tried to do it with apt-get and both times it failed with same error:
root@gitlab-srv:~# sudo apt-get install gitlab-ee=11.11.5-ee.0 Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: linux-headers-4.4.0-131 linux-headers-4.4.0-131-generic linux-headers-4.4.0-141 linux-headers-4.4.0-141-generic linux-image-4.4.0-131-generic linux-image-4.4.0-141-generic linux-image-extra-4.4.0-131-generic linux-image-extra-4.4.0-141-generic Use 'sudo apt autoremove' to remove them. The following packages will be upgraded: gitlab-ee 1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. 40 not fully installed or removed. Need to get 729 MB of archives. After this operation, 25.5 MB disk space will be freed. Get:1 https://packages.gitlab.com/gitlab/gitlab-ee/ubuntu xenial/main amd64 gitlab-ee amd64 11.11.5-ee.0 [729 MB] Fetched 729 MB in 5min 22s (2,263 kB/s) (Reading database ... 244163 files and directories currently installed.) Preparing to unpack .../gitlab-ee_11.11.5-ee.0_amd64.deb ... /opt/gitlab/embedded/bin/ruby: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /opt/gitlab/embedded/lib/libruby.so.2.5) dpkg: error processing archive /var/cache/apt/archives/gitlab-ee_11.11.5-ee.0_amd64.deb (--unpack): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/gitlab-ee_11.11.5-ee.0_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
Since this I cannot even run gitlab-ctl or even backup my gitlab, every gitlab related command fail with same error:
/opt/gitlab/embedded/bin/ruby: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /opt/gitlab/embedded/lib/libruby.so.2.5)
It seems that I currently got a failed 11.11.4 version!
- gitlab-ee 11.11.4
- gitlab-config-template 11.11.4
- gitlab-cookbooks 11.11.4
I wanted to upgrade my ubuntu to 18.04 but since i have an unfinished package to install I wasnt able to proceed with that too!
I even tried to downgrade it to the last working version but for that it need ruby and it seems all problems are coming from
I appreciate any help,