Cannot clone with SSH from GitLab.com, Server Requires Public Key Authentication

Hello all,

I know this question has been asked a lot, but I have a Windows PC now in a state where SSH will not work. I have attempted the following:

  • Deleting all Keys in USER/.ssh, also deleting Known_Hosts

  • Deleting all Public Key tokens in GitLab in my User Profile for GitLab

  • Recreating a fresh set of keys according to this procedure: https://gitlab.com/help/ssh/README#generating-a-new-ssh-key-pair

  • I have attempted both rsa as well as ed25519, both result in Fatal: Cannot Read from Repository

  • I tried creating keys with unique names, and -add to ssh-agent

  • I tried adding a ssh config file to the .ssh folder

  • I went so far as to re-install Git on windows. Still no ability to use SSH with GitLab.

I am the Owner of the repository, and confirmed that HTTPS: access is working. I have deployed the ssh -Tv test, with debug output going all the way through SSH2_MSG_SERVICE_ACCEPT received…immediately followed by "received disconnect from SERVER_IP port 22:2: Connection blocked because server only allows public key authentication.

This is GitLab’s hosted solution, not a local server. This PC was working with SSH less than a day ago (originally with rsa key pairs). Only items I can think of that might be relevant:

  • I have since commissioned a Vagrant box, Vagrant wanted increased security and created it’s own SSH key for the VM located in a non-standard ssh directory. I was able to use the repo after this step, so I don’t think this is the error but am reporting our of desperation

  • I had to change the Vagrant Box IP address due to a conflict with DHCP assignment. this updated so addresses of virtual network cards. ( did not commit changes since doing this, SSH failure was discovered)

I should be clear I am not trying to use SSH from within a Vagrant box, I am simply reporting some operations I was doing before discovering the failure. I am trying to get my Host Windows machine to use SSH auth for my repository.

Any help is appreciated, feeling lost.

Thank you,

1 Like