Cannot login after upgrading from v16.7.3

Unable to login after upgrade

I want to upgrade from v16.7.3 upwards. We are using docker-compose version. All upgrades until now worked flawlessly (following official documentation: Install GitLab by using Docker | GitLab)

After upgrade to any version (tested: 16.7.7, 16.8.5, 16.9.1) - logging in with user/pass returns unrecognized user.
Although SSH access works, as well as logging in with root user (but not any other user).
I also tried to set(change password) in two ways (following Reset a user's password | GitLab):

  • through dashboard (logging in with root user)
  • through gitlab-rake entering docker container
    Email arrived informing about password change, but still not able to login.



version: "3.3"
    image: gitlab/gitlab-ce:16.7.3-ce.0
    restart: always
    hostname: ''
        external_url '<GIT.EXAMPLE.COM>'
        letsencrypt['enable'] = false
        nginx['redirect_http_to_https'] = false
        registry_nginx['redirect_http_to_https'] = false
        mattermost_nginx['redirect_http_to_https'] = false
        nginx['listen_port'] = 80
        nginx['listen_https'] = false
        gitlab_rails['smtp_enable'] = true
        gitlab_rails['smtp_address'] = ""
        gitlab_rails['smtp_port'] = 587
        gitlab_rails['smtp_user_name'] = "<SMTP_GMAIL_ADDRESS>m"
        gitlab_rails['smtp_password'] = "<SMTP_GMAIL_PASSWORD>"
        gitlab_rails['smtp_domain'] = ""
        gitlab_rails['smtp_authentication'] = "login"
        gitlab_rails['smtp_enable_starttls_auto'] = true
        gitlab_rails['smtp_tls'] = false
        gitlab_rails['smtp_openssl_verify_mode'] = "peer"
      - '80:80'
      - '22:22'
      - '$GITLAB_HOME/config:/etc/gitlab'
      - '$GITLAB_HOME/logs:/var/log/gitlab'
      - '$GITLAB_HOME/data:/var/opt/gitlab'


Version: 16.7.3 ‹- working (able to login)
Version: 16.7.7, 16.8.5, 16.9.1 ‹- NOT working (NOT able to login)

I’m worried

…because I’m facing this message-box all the time and I cannot move forward with any upgrade:

Any help is highly appreciated.