Can't pull from my container registry, others can

Can’t pull from my container registry, others can

I’m trying to pull from my private container registry at, but I can’t. Yesterday I (remotely) guided someone through the same process and they were successful.

I’ve created a personal access token, and done the following:

felix@felix-B550-AORUS-PRO-AX:~/src/ht_planner_ws$ docker login -u felix-h-kong
Login Succeeded
felix@felix-B550-AORUS-PRO-AX:~/src/ht_planner_ws$ docker pull
Error response from daemon: Head "": unauthorized: HTTP Basic: Access denied

I expected it to pull like it usually does, but it looks like I don’t have the right login credentials. I put my token in as the password during docker login, as per the instructions here. I made sure my personal access token has api, read_registry (and also write_registry, but whatever).

I feel like it must be something to do with my configuration or credentials, since I was able to guide my colleague through it. My ~/.docker/config.json looks like this:

        "auths": {
                "": {}
        "credsStore": "secretservice"

I have also tried deleting this config file and retrying docker login and docker pull, but I get hte same error.

I did recently change my username, so maybe that has something to do with it? But I created a new personal access token after the username change, and docker login returned Login succeeded, so maybe that’s not it.

I’m on Docker version 20.10.14, build a224086.

Any help would be appreciated!

Make sure you tick read_registry when creating your PAT

Yeah I’ve got that - I’ve got api, read_registry, and write_registry.