Can't see projects/repos in Sourcetree

So I’ve used Sourcetree to manage GitLab (Cloud) projects on my older PC, no issues. I bought a new laptop and wanted to set it up and clone projects, so I can do some work.

I connected to my GitLab account successfully in Sourcetree using personal access token (it has API and read_user permissions), it shows green checkmark. But for some reason, I don’t see any of my projects. Clicking refresh doesn’t help.

I have the checkbox checked to show organization repos. I see the dropdown with all my groups/sub-groups. But when I go through them in the dropdown, it’s blank - no projects show for any of them.

Weird thing is, when I uncheck show organization repos and then check it again, it will show all projects on the list. The moment I use the dropdown again to limit projects to the sub-group, it all goes blank again. And I can’t get back to a list of all projects unless I uncheck/check organization repos again.

Anyone has seen anything like that? I don’t know if it’s a GitLab API issue or Sourcetree. Didn’t have this problem before. Sourcetree is at the latest version 3.3.9. Tried restarting it. Tried switching between embedded and system Git, same issue.