CE - Version not showing in help menu

So I admin a few GitLab CE servers and one of them (my first) doesn’t show the version of GitLab-CE which is currently running, despite the fact I am the admin user


I’m concerned that an upgrade process didn’t complete properly at some point and that maybe other things (which I haven’t noticed) might not be 100%

I finally decided to install a brand new Gitlab-CE instance (16.9.0) and do a migration to once and for all be certain that my CE instance was 100% correct. I installed 16.9.0 on Ubuntu (jammy) last night, and checked and the menu/version was there when I logged in as root.

I then did a backup and restore following the instructions online and having logged into the new server following the restore, the version string is again missing.

So now I’m wondering if all of this is just a missing permissions attribute on my user? So I added another admin user … and they can’t see the version string either.

This has been driving me insane for quite literally months now … what am I missing? It has to be something relatively simple.

Other CE servers I admin (mainly on Debian) all show the version string … just my own personal CE instance that doesn’t. Why is this?



Some things to try:

gitlab-ctl reconfigure
gitlab-ctl restart
systemctl restart gitlab-runsvdir

see if it comes up after that, if not, try clearing Redis cache just incase:

gitlab-rake cache:clear

Run a sanity check to see if any problems come up:

gitlab-rake gitlab:check

and potentially check migration status to see if they are all “up”:

gitlab-rake db:migrate:status

Another handy command to use, if for example all migrations show “up”, but appear in the list when using this command:

gitlab-rails runner -e production 'puts Gitlab::Database::BackgroundMigrationJob.pending[0].pretty_inspect'

if it shows nil then all is OK, if you have some results from that last command, then they most likely will need addressing and checking in detail.

Also, visit Admin Area, since on one of the screens there it should show the Gitlab version too on the dashboard.

1 Like

Thanks for the speedy response

I’ve already tried a reconfigure, restart, etc although I have now repeated / gone through every command you have suggested to be thorough

All migrations appear up (6,435 lines output from that one!)

gitlab:check reports OK
gitlab-rails runner -e production ‘puts Gitlab::Database::BackgroundMigrationJob.pending[0].pretty_inspect’
reports nil

Now it does show the Gitlab version in the Dashboard screen, however I don’t understand why it is no longer showing in the menu …

Edit: Now updated both to 16.9.1-ce having already running all of the above … still no change / version info in the Help menu :frowning:

Can you check:

Admin Area → Settings → Metrics and profiling → Usage statistics

Can you ensure “Enable version check” and “Enable Service Ping” are checked/enabled? Then save the changes, and see if it appears under Help?



Enable Version Check wasn’t ticked … and that appears to have resolved that particularly niggling little issue after a log out / log back in

You won’t believe how much worry that tiny little status field has caused … did I screw up an update at some point, did one of the upgrades not finish properly and I didn’t notice, what have I messed up, etc, etc

Thank You … you’re a genius! :slight_smile:

1 Like