Configuring CI with Gitlab HTTPS access using Apache

Hi there :smile: !

I am having a hard time trying to configure Gitlab CI. As i’m not a pro yet in network protocol and HTTPS

Theses are the steps i have done until now in vain:

  • Installed Gitlab from Omnibus installation
  • Disabled NGINX and added setup for apache
  • Configured apache config vhost for port 80 and 443 allowing only connections in https with letsencrypt certificate line
  • Installed gitlab runner and registered one using certificates from letsencrypt apache previously mentionned executor “docker”
  • Gitlab is accessible as wanted in HTTPS
  • Created a project, a repo and a gitlab-ci.yml file just for testing with only echo “hello world” on build.
  • I tried to add certificate for gitlab as /etc/gitlab/trusted-cert/

When I run a job, the runner returns the following error :

And also

my config.toml for runner is like bellow:

And this is my apache HTTPS config (only VHOST 443)

Important note:

Installed with nginx and using letsencrypt integration is ok it works just fine HTTPS, runner register job done and gitlab-ci.yml description executed correctly ! It creates file in trusted-cert folder under /etc/gitlab/, No needs to configure any specific TLS certs everything is done for me as magic ! :mage::fairy:

More information :

If I mention tls-ca-file to fullchain.pem, the output error changed to cannot get (local) issuer certificate.

Have you got any tips or helps to fix my issue ? :smile:

Yeay: :wink: I fixed it thanks to apache configuration that was not configured correctly i was using port 8080 instead of port 8181 and not told to gitlab.rb to listen on… google took a long time to answer me correctly: