Confusing permission request when authorizing for "login with gitlab"

The first time I tried using, I tried logging in with gitlab, however this appears to request “complete read/write access”, with the following page:

Authorize to use your account?
An application called is requesting access to your GitLab account. Please note that this application is not provided by GitLab and you should verify its authenticity before allowing access.

This application will be able to:

Access the authenticated user’s API
Grants complete read/write access to the API, including all groups and projects.

Does this mean that agreeing to this authorization, would get access to all my code, etc. in all of my repos? That seems overly broad and completely unnecessary, considering that I assume would only need information about my identity (say, username, profile picture, maybe email address), but I see no reason why it would actually need access to my repos. Still, this is what the above text appears to indicate, so I obviously didn’t accept it and created a new account (i.e. login with email) for

Note that there is an old question from two years ago about the same topic, but that received no answers, see