Docker Hub Public Image Module Vulnerability

The gitlab docker image gitlab14.2.2-CE.0 published on the Docker hub contains openssh8.2.
As of October 1, 2021, you need to upgrade your versions of openssh below 8.7 to openssh 8.8.
Did you make sure you weren’t affected by the vulnerabilities before and after the Docker build?

Current stable version of OpenSSH is 8.7. Not enough information in your post as to why OpenSSH lower than 8.7 is a problem. Considering a lot of current stable versions are using for example 7.9 (Debian 10) and bugfixes are made to these to resolve any vulnerabilities.

Either way, if you believe it to be a problem, open an issue here: Issues · / GitLab · GitLab but you are going to have to provide a lot more information than you have before even anyone will take a look at it. Just saying or claiming there is a vulnerability without explaining any detail is useless and such a request will be rejected/ignored.