Docker runner fails with fatal error git repository not found

Pipeline Job fails cloning a repository using http, I am using docker gitlab-runner:latest and gitlab-ce:latest. I have changed the repository from internal to public without success, cloning the public repo manually from the runner shell works OK

Below job log output

++ echo ‘Cloning repository…’
++ git clone --no-checkout /builds/6e783fe4/0/group/repo --template Cloning repository…
Cloning into ‘/builds/6e783fe4/0/group/repo’…
fatal: repository ‘’ not found
ERROR: Job failed: exit code 1

How, or where the gitlab-ci-token is produced ?, I only managed to clone the repo manually from the docker (container) runner passing some gitlab access token

I ran a new gitlab container, and configured nginx to listen on the same port exposed by the container, previously nginx was listening on a different port than the port exposed by the container ( the external URL port ). The problem gets solved this way

Still I don’t know if the problem was some corruption with gitlab-ci-token, or the fact the external URL port was different from nginx listening port