Error installing jekyll

Hi, I’ve been trying to deploy some updates to my page, but the pipeline keeps failing:

Building native extensions. This could take a while…
ERROR: Error installing jekyll:
ruby_dep requires Ruby version >= 2.2.5, ~> 2.2.
Successfully installed ffi-1.9.23
Successfully installed rb-inotify-0.9.10
Successfully installed sass-listen-4.0.0
Successfully installed sass-3.5.6
Successfully installed jekyll-sass-converter-1.5.2
ERROR: Job failed: exit code 1

I’ve tried this via a CI pipeline as well, and got the same error. Anyone has any tips on how to resolve this? I’m not the most experienced person with Git, so any help would be appreciated. Many thanks!