Error running CI in a basic voidlinux container

For testing my library in different environments, I’ve set up a number of containers.
One contributor uses voidlinux (with musl), so I added this system to the list.
Unfortunately the job fails with the following error:

Executing "step_script" stage of the job script  
  00:00 Using docker image  sha256:50f026380bd6ec5454e99360aa8194493c6f0ef26094518e26e228a62a2033bd for ghcr.io/void-linux/void-musl:latest with digest ghcr.io/void-linux/void-musl@sha256:b9a84aa78229a8b3f30b6036933b887964d72478c580c3f2e76c138b8c96967e ...
/usr/bin/sh: 7: Syntax error: Unterminated quoted string

I narrowed it down to a helloworld example with the official voidlinux image. Here’s a yml that results in the same error:

stages:
  - check

check_step:
  stage: check
  image: ghcr.io/void-linux/void-musl:latest
  script:
    - echo 'Hello world'

Tried replacing echo with pwd or ls - doesn’t matter.
How would I approach debugging this issue? Is it a bug in the container or on gitlab? Searching the web or this forum gave zero results.
Any help is appreciated.

Tried using CI_DEBUG_TRACE variable, but it only shows successful commands before the error (which is set +o with some option). The actual command which has failing quote remains unknown. There is definitely no quotes in the yml, so it’s something from the generated bash script. If I could find out what that bash script contains, I could run it manually in mentioned container to see why it’s failing.