Error to update 16.2.8 to 16.3.0

Hi,

I tested several versions in 16.3.x but none worked, still the same error.

Preparing to unpack .../gitlab-ce_16.3.0-ce.0_amd64.deb ...
* grafana[enable] has been deprecated since 16.0 and was removed in 16.3. The bu                                                                                                                                                             ndled Grafana is deprecated and no longer available. We recommond following
https://docs.gitlab.com/ee/administration/monitoring/performance/grafana_configu                                                                                                                                                             ration.html#deprecation.
Deprecations found. Please correct them and try again.
dpkg: error processing archive /var/cache/apt/archives/gitlab-ce_16.3.0-ce.0_amd                                                                                                                                                             64.deb (--unpack):
 new gitlab-ce package pre-installation script subprocess returned error exit st                                                                                                                                                             atus 1
Errors were encountered while processing:
 /var/cache/apt/archives/gitlab-ce_16.3.0-ce.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Remove the grafana configuration from /etc/gitlab/gitlab.rb - the error message says grafana[enable] has been deprecated since 16.0.

I have remove and i have this message

The following packages were automatically installed and are no longer required:
  apache2-bin apache2-data apache2-utils cdebootstrap debian-archive-keyring libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libdebian-installer-extra4 libdebian-installer4 libjansson4 liblua5.2-0 libxmlb1
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  gitlab-ce
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
13 not fully installed or removed.
Need to get 1,085 MB of archives.
After this operation, 141 MB disk space will be freed.
Get:1 https://packages.gitlab.com/gitlab/gitlab-ce/ubuntu focal/main amd64 gitlab-ce amd64 16.5.3-ce.0 [1,085 MB]
Fetched 1,085 MB in 14s (75.2 MB/s)
(Reading database ... 129843 files and directories currently installed.)
Preparing to unpack .../gitlab-ce_16.5.3-ce.0_amd64.deb ...
gitlab preinstall: It seems you are upgrading from 16.2 to 16.5.
gitlab preinstall: It is required to upgrade to the latest 16.3.x version first before proceeding.
gitlab preinstall: Please follow the upgrade documentation at https://docs.gitlab.com/ee/update/index.html#upgrade-paths
dpkg: error processing archive /var/cache/apt/archives/gitlab-ce_16.5.3-ce.0_amd64.deb (--unpack):
 new gitlab-ce package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/gitlab-ce_16.5.3-ce.0_amd64.deb

The error message above shows why:

gitlab preinstall: It seems you are upgrading from 16.2 to 16.5.
gitlab preinstall: It is required to upgrade to the latest 16.3.x version first 

as per the Gitlab upgrade docs: Upgrade GitLab | GitLab

clearly shows that 16.2.8 needs to be upgraded to 16.3.6 first, so:

apt-get install gitlab-ce=16.3.6-ce.0

16.3.7 is available, so in theory you can do:

sudo apt-get install gitlab-ce=16.3.7-ce.0

instead of going to 16.3.6 first.

Yes my bad its fix thanks you guy

1 Like