Error when using webhooks

Hi,
Im attempting to run a webhook into MS Teams but when I test the hook from GitLab I get the following error:-

“hook executed successfully but returned HTTP 400 summary or text is required”

I can run the command manually and its successful.

curl -H “Content-Type: application/json” -d “{“text”: “Hello World”}” https://hookaddress

Using different versions of GitLab CE and have just tried 8.14.0 with the same error

Anyone advise?

Thanks.

1 Like

I also see this error with MS Teams. This prevents MS Teams from getting notifications from GItLab webhooks.

Is this solved? I am having the same issue with Gitlab version 9.4.5

The gitlab help docs have test JSON body that you can use to test from postman:

{
“object_kind”: “merge_request”,

The error “…summary or text is required” is coming from MS Teams. The body needs to include a “summary”: “value” or “text”: “value” in the JSON body. Notice how the curl command has a value for “text”. That’s why it works. Why gitlab is not included this vital piece of data is unknown to me. Probably a defect.