Errors after upgrade from 12.3.5 to 12.4 with docker

I have an gitlab running behind apache in docker with fixed version.
sudo docker run --detach --hostname --publish 4430:443 --publish 800:80 --publish 65222:65222 --publish 63322:63322 --name gitlab --restart always --volume /srv/gitlab/config:/etc/gitlab --volume /srv/gitlab/logs:/var/log/gitlab --volume /srv/gitlab/data:/var/opt/gitlab gitlab/gitlab-ce:12.3.5-ce.0

After stopping, removing and running the container with image gitlab/gitlab-ce:latest, i cannot access the GitlabInstance anymore, while every request responses with a 500-error page.

The only error log i can find is following in /logs/gitlab-rails/production.log:

NoMethodError (undefined method `throttle_protected_paths_enabled?' for #<ApplicationSetting:0x00007f90caf1abf0>
Did you mean?  throttle_authenticated_api_enabled?):

config/initializers/rack_attack_new.rb:8:in `protected_paths_enabled?'
config/initializers/rack_attack_new.rb:62:in `block in <class:Attack>'
lib/gitlab/middleware/read_only/controller.rb:48:in `call'
lib/gitlab/middleware/read_only.rb:18:in `call'
lib/gitlab/middleware/basic_health_check.rb:25:in `call'
lib/gitlab/request_context.rb:32:in `call'
lib/gitlab/metrics/requests_rack_middleware.rb:49:in `call'
lib/gitlab/middleware/release_env.rb:12:in `call'

If i revert the upgrade and start the container with the fixed version 12.3.5 everything starts working again.

The config section for Rack_Attack in gitlab.rb (gitlab_rails['rack_attack_git_basic_auth']) is disabled /commented out and nothing else for rack_attack is enabled.
I also tried to disable it hard with gitlab_rails['rack_attack_git_basic_auth'] = {'enabled' => false} with the same result.

What can i do?

1 Like

I also have the same problem after upgrading to 12.4.0. I suspect this is a bug in the latest release.

Iā€™m running GitLab on native Debian (not using Docker). I went through the recommended upgrade path starting from v10.7.0 and installed the required middle versions.

After upgrading the same way to the new version 12.4.1 everything is fine again.
Thx Gitlab :slight_smile: