External .gitlab-ci.yml setting ignored

Hello,
I’m working on a self-hosted GitLab instance at my organization running GitLab 14.2 with the premium feature tier. I’m currently trying to set up CI on a project using a yml file stored on another repo in the same group.

Initially, I tried using the URL configuration with a link to the raw yml file: https://ourgitlab.com/ourgroup/otherrepo/-/raw/main/.gitlab-ci.yml as mentioned here. I received a message stating “Pipelines settings for ‘Ourproject CI’ were successfully updated.”

But, when I went to the CI section, it told me to create a .gitlab-ci.yml file.


Since that didn’t work. I tried changing the visibility of each repo to public, but that didn’t have an effect. Then, I tried using the group syntax instead. I set it to .gitlab-ci.yml@ourgroup/ourproject as stated in the docs, and it is still is trying to get me to make a .gitlab-ci.yml file. Is there anything I’m missing here, or is there perhaps a bug?

Thanks!

Rusty

Hi,

this seems to be a bug, I have reproduced your described behaviour, with a different error condition though (install runners). I’ve opened an issue at Remote CI/CD config URL project setting does not show pipeline view (#341258) · Issues · GitLab.org / GitLab · GitLab - please add your version specific details into a new comment too. Thanks!

I’ve found a workaround while debugging - if you enable Auto DevOps once (no further config), the pipeline view is there for the project and you can run the pipelines. Still, that’s not the desired behaviour and should be fixed.

Kind regards,
Michael