Failed to load puma Error (after migrating from 14.7.3 -> 14.8.0 docker installation)

Hello everybody,

I had a Gitlab v14.7.3 instance running and followed as usual the steps described here: GitLab Docker images | GitLab

However, with the v14.8.0 image, Gitlab is not starting. Hopefully switching back to the v14.7.3 is working.

I’m getting the following error (at least it’s the only one I managed to see in the docker logs):

==> /var/log/gitlab/puma/current <==
2022-02-23_16:21:09.58286 {"timestamp":"2022-02-23T16:21:09.582Z","pid":1569,"message":"! Unable to load application: NoMethodError: undefined method `devise' for #\u003cClass:0x00007fabc2456300\u003e"}
2022-02-23_16:21:09.58311 bundler: failed to load command: puma (/opt/gitlab/embedded/bin/puma)
2022-02-23_16:21:09.58384 NoMethodError: undefined method `devise' for #<Class:0x00007fabc2456300>

Did I missed something?

Thank you.

I just saw an update that there is the 14.8.1 update.

I also tried with that image, but I still have the same issue :confused:

I have the exact same issue. Omnibus 14.7.3 → 14.8.1

Probably the number of puma processes are set to 0, more details in puma: Unable to load application: NoMethodError: undefined method `devise' after upgrade to 14.8.0 (#6692) · Issues · / omnibus-gitlab · GitLab

That was it! Thank you very much!

I set the Puma processes to 0 based on this official guide to optimise memory usage: Running GitLab in a memory-constrained environment | GitLab


Thanks, added your case with the docs into the issue too :slight_smile:

I also apply those exact same optimizations and had the puma worker processes also set to 0.
I’ll change that to 1 and try.
Thank you.

Just for the record: we slightly modify the upstream docker image and add some custom scripts. We do build this in a GitLab-CI job and set Puma worker_processes in the CI job service configuration to 0 as well and ran into the same error. Setting this to 1 solved the problem for us as well.