Failed to update from 16.2.1 to 16.3.0

When trying to upgrade from version 16.2.1 to 16.3.0 I am getting a message saying that I am already running the latest version… somehow it is not recognizing the existence of version 16.3.0…

I am running Ubuntu 22.04.3 LTS.

I issue a command from the command line interface (command prompt window). Command I use for upgrade is the same I have been using since upgrading from 12.10.3 to 13.0.1:

root@lxdy47ap08:~# apt-get update && apt-get install gitlab-ee

Full “log” when command is executed is the following:

root@lxdy47ap08:~# apt-get update && apt-get install gitlab-ee
Hit:1 Index of /ubuntu jammy InRelease
Hit:2 Index of /ubuntu jammy-security InRelease
Hit:3 Index of /ubuntu jammy-updates InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
gitlab-ee is already the newest version (16.2.1-ee.0).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Can anyone throw some light? thanks!

Did you pin the version?
Have a look at /etc/apt/preferences.d/gitlab.pref if this exists.

Try running this first

curl | sudo bash

then do your apt-get update && apt-get install gitlab-ee

Let us know if it worked :slight_smile:

1 Like

Dear doctor3182:

After running this script, I got the following output:

root@lxdy47ap08:~# curl | sudo bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 6865 100 6865 0 0 24459 0 --:–:-- --:–:-- --:–:-- 24517
Detected operating system as Ubuntu/jammy.
Checking for curl…
Detected curl…
Checking for gpg…
Detected gpg…
Running apt-get update… done.
Installing apt-transport-https… done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ee.list…done.
Importing packagecloud gpg key… done.
Running apt-get update… done.

The repository is setup! You can now install packages.

And after that, issuing my command worked like a charm. Thank you for your assistance.
I am not sure if I fully understand what this script did and how running it solved my problem. Did I do something wrong in the first place? I am just concerned that this solved my problem and I do not understand why… But thanks anyway. Now my environment is fully upgraded, thanks to you!

1 Like

Hi @rmattos :fist_right: Glad to hear the issue is resolved :slight_smile:
This command just updated gitlab repository on your machine, this way you can now see latest versions, I have a feeling previous repository was out of date :slight_smile: