Permission denied (publickey,keyboard-interactive) in last days without reason

I’ve been using GitLab from a couple of years without issues, but from last week it started to reject the connection when I try to push a commit with the error message: Permission denied (publickey,keyboard-interactive).
I didn’t change my ssh key, and it happens to both my desktop and my laptop (with 2 different key obviously). Sometime I have to try several times and it finally work, today it doesn’t work at all.
It seems no one else is suffering this problem, I don’t really understand what happened?!

It’s such a relief seeing someone else having this same issue! I thought I was going crazy! Intermittent fails and today stopped working completely, I cannot run a simple “pull” from my repo anymore.

Me too!

ssh -Tv shows:

debug1: Offering public key: /home/daryll/.ssh/id_rsa RSA SHA256:HASH agent
debug1: send_pubkey_test: no mutual signature algorithm

I worked around it by doing ssh-keygen -t ed25519 and adding that new public key to gitlab. That key allowed my pulls to work.

Seems like something broke.

Looks like the Fedora bug with the workaround mentioned at:

1 Like

Thanks, I solved by installing this upgrade

Now it works correctly.


For reference, I’m a Fedora user as well. The change to the ssh config allows the RSA key to work.

I have the same problem on macOS Catalina.

Can also confirm issue occurs on Catalina and Big Sur with RSA and ED25519 keys

I have the same issue

Same issue here, macos Big Sur.