Git@gitlab.com: Permission denied (publickey,keyboard-interactive) since today only

,

I’ve been using GitLab for a couple of months now without any issues. Today, I cant pull from my private repo anymore. I get a git@gitlab.com: Permission denied (publickey,keyboard-interactive) error.

Although, when I test the connection with ssh -Tv git@gitlab.com I get debug1: Authentication succeeded (publickey).

I have tried recreating a new key, but still get the same outcome.

Anyone else getting this problem? I’m on Windows.

I’m experiencing the same issue.

tomorrow my key stopped working

how did you solve?

Never did :frowning:

I’m currently using https instead until I can find a solution.

in the meantime i found a solution

i resolved installing the new version of openssh for windows:

Ah! I haven’t thought about that. Ill give it a try tonight thanks!

Regards,

I am also experiencing the same issue. I re-created both ssh and gpg keys for the repository. I can also verify that it is not working with public repositories, as I am unable to pull from them, as well.

Update:
It seems like the latest update to openssh has changed quite a few things, and has caused conflicts with gitlab. I was able to bypass the error by specifically pointing to the ssh key using this:

git clone git@gitlab.com:<path_to_repo>.git --config core.sshCommand="ssh -i <path_to_ssh_private_key>"

Hopefully this helps someone.