Gitlab 8.7.0 - GitLab API access: FAILED: Failed to connect to internal API

I have a nearly fully functional Gitlab set up. HTTPS connection is valid and has proper certs. Using Nginx.

My issue is that when I tried to push/clone to Gitlab, it would fail. When I was originally setting it up, I brushed off this error message as everything else worked but clearly it’s important. I’ve searched through the entire first two pages of google, but none of the solutions seem to apply here. (They’re usually based on fault connections in config.yml like not setting http(s)://). I’m using letsencrypt for my SSL certs and they’re in the directory “/etc/letsencrypt/live/”. Am I using the proper file for ca_file in gitlab-shell/config.yml?


System information
System:		Ubuntu 14.04
Current User:	git
Using RVM:	no
Ruby Version:	2.1.8p440
Gem Version:	2.2.5
Bundler Version:1.11.2
Rake Version:	10.5.0
Sidekiq Version:4.0.1

GitLab information
Version:	8.7.0
Revision:	f2afc5d
Directory:	/home/git/gitlab
DB Adapter:	mysql2
SSH Clone URL:
Using LDAP:	no
Using Omniauth:	yes
Omniauth Providers: 

GitLab Shell
Version:	2.7.2
Repositories:	/home/git/repositories/
Hooks:		/home/git/gitlab-shell/hooks/
Git:		/usr/local/bin/git


GitLab Shell version >= 2.7.2 ? ... OK (2.7.2)
Repo base directory exists? ... yes
Repo base directory is a symlink? ... no
Repo base owned by git:git? ... yes
Repo base access is drwxrws---? ... yes
hooks directories in repos are links: ... 
User / TestRepo ... repository is empty
Running /home/git/gitlab-shell/bin/check
Check GitLab API access: FAILED: Failed to connect to internal API
gitlab-shell self-check failed
  Try fixing it:
  Make sure GitLab is running;
  Check the gitlab-shell configuration file:
  sudo -u git -H editor /home/git/gitlab-shell/config.yml
  Please fix the error above and rerun the checks.

Checking GitLab Shell ... Finished
Checking Sidekiq ...
Running? ... yes
Number of Sidekiq processes ... 1
Checking Sidekiq ... Finished
Checking Reply by email ...
Reply by email is disabled in config/gitlab.yml
Checking Reply by email ... Finished
Checking LDAP ...
LDAP is disabled in config/gitlab.yml
Checking LDAP ... Finished
Checking GitLab ...
Git configured with autocrlf=input? ... yes
Database config exists? ... yes
All migrations up? ... yes
Database contains orphaned GroupMembers? ... no
GitLab config exists? ... yes
GitLab config outdated? ... no
Log directory writable? ... yes
Tmp directory writable? ... yes
Uploads directory setup correctly? ... skipped (no tmp uploads folder yet)
Init script exists? ... yes
Init script up-to-date? ... yes
projects have namespace: ... 
Nick / CryptRef ... yes
Redis version >= 2.8.0? ... yes
Ruby version >= 2.1.0 ? ... yes (2.1.8)
Your git bin path is "/usr/local/bin/git"
Git version >= 2.7.3 ? ... yes (2.7.4)
Active users: 1

Checking GitLab ... Finished


user: git
  self_signed_cert: false
ca_file: "/etc/letsencrypt/live/"
ca_path: "/etc/letsencrypt/live/"

repos_path: "/home/git/repositories/"
auth_file: "/home/git/.ssh/authorized_keys"
  bin: "/usr/bin/redis-cli"
  namespace: resque:gitlab
  socket: "/var/run/redis/redis.sock"
log_level: INFO
audit_usernames: false

Hi there, any luck in getting to the bottom of your issue? I’m experiencing similar issues with a freshly installed 8.7.3 instance on Ubuntu 16.04. However, I only intermittently get this problem (~ 30% of the time). Just now I ran:

sudo gitlab-rake gitlab:check

first time success, second time failure. I’d rather it never worked or, of course always worked! It’s certainly enough to cause my Jenkins to develop a major hate for me. I really don’t want to go back to gitolite, but may be forced to soon.

I should mention I am trying to run unbundled nginx.