Gitlab-CE won't connect after power loss

I have a personal gitlab server that is running on a raspberry pi 4. It had recently lost power and now I cannot connect to the gitlab server. I made sure that the pi had power, I reconfigured gitlab and I restarted it but I cannot connect to the webpage through the URL entry at top of chrome. I can ssh into the pi from outside the network using the following command ssh -p 22 Not sure what the error is. I have certbot installed not sure how to check if it is running.

First check:

gitlab-ctl status

make sure everything is running. If it is, then you can try reconfiguring to see if it fixes your problems, so:

gitlab-ctl reconfigure
gitlab-ctl restart

and see if that helps.

I can see everything running but even when I reconfigured last time it wouldn’t connect. I can try again.

I am going to be honest, I am a noob at this gitlab-ce self managed stuff and do not know what I am looking at when I run the status. I had it working with SSL encryption and I do not see letsencrypt running

Also the exact error that chrome is giving me is ERR_CONNECTION_RESET

LetsEncrypt as far as I know doesn’t run as a service anyway. So you wouldn’t normally see this I don’t think. For mine I did LetsEncrypt externally outside of Gitlab so I’ve no idea personally what it would look like.

Sometimes a restart of this service is needed, or just reboot so that everything restarts (unless you have already done this):

systemctl restart gitlab-runsvdir

otherwise, without logs, difficult to help you fix it. You will need to look at all the log files under /var/log/gitlab and see if you find anything that looks to be errors or something related to a problem with your system.

I guess I never properly reboot the system so I will try that now. O.W I will look into the logs. Thank you

So that didn’t work and I am currently looking through log files. So far the only thing that I have found is that the reconfigure log files before and after power loss of significantly different in terms of length and content. Also, I tried just typing in the local network IP address of the pi in the URL bar and I got a default apache2 debian page that is telling me to replace the file located at /var/www/html/index.html. I guess this is good since I can reach the pi and it is a web server but it is not displaying gitlab. My guess is that I need to link it to a gitlab file/directory (?) not sure.

After clearing browser data, I get the apache default page when I type the url in from outside the network. So it can access the server but it is not running properly. I understand its not very useful without logs, I am still looking through them to see if there is anything I can discern.

Apache could be causing issues then, especially if Gitlab is supposed to be running on port 80 or 443 like it should do normally.

I suggest stopping Apache, restart Gitlab and see if it’s accessible. This is of course, assuming that your install used the standard ports from a normal install and not customised or change to something else.

Yup that worked! Thank you so much for your help!

1 Like