Gitlab Ci/CD fails when running apt-get update

I have below part of gitlab .gitlan-ci.yml:

build_deploy_stage_prod:
  only:
    - prod
  script:
    # BUILD STAGE
    - rm ./package-lock.json
    - npm install
    - npm run build-prod
    - ls -l dist/js

    # DEPLOY STAGE
    # SSH setup
    
    - apt-get update -qq
    - 'which ssh-agent || ( apt-get install openssh-client -y )'
    - 'which rsync || ( apt-get install rsync -y )'

build fails on command:

apt-get update -qq

This is the error log:

Running with gitlab-runner 11.10.0-rc2 (1xxxxx05) on
docker-auto-scale 02xxxx0f Using Docker executor with image
node:8.10.0 … Pulling docker image node:8.10.0 …

---- log removed ------

ls -l dist/js total 1072 -rw-r--r--. 1 root root 163825 Apr 21 07:34 app.775fb8a4.js -rw-r--r--. 1 root root 923861 Apr 21 07:34 chunk-vendors.4168545b.js apt-get update -qq W: Failed to fetch
http://deb.debian.org/debian/dists/jessie-updates/InRelease Unable to
find expected entry ‘main/binary-amd64/Packages’ in Release file
(Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old
ones used instead. ERROR: Job failed: exit code 1

Exact same CI/CD worked fine one month ago but today when I ran the pipeline got the error as documented.

How to fix this problem?

additional logs of the gitlab runner:

$ uname -a Linux runner-fxxcab46-project-8088403-concurrent-0
4.19.23-coreos-r1 #1 SMP Mon Feb 25 23:40:01 -00 2019 x86_64 GNU/Linux

$ cat /proc/version Linux version 4.19.23-coreos-r1
(jenkins@ip-24-7-32-103) (gcc version 7.3.0 (Gentoo Hardened 7.3.0-r3
p1.4)) #1 SMP Mon Feb 25 23:40:01 -00 2019