Gitlab CI/CD stuck on submodule update

Hello everyone,
first of all, I want to thank you for trying to help me :).
I m trying in my .yml to use the git submodule init and update.
The problem is that the submodule update updates the first 4 or 5 submodules and then get stuck until the time runover:
image


I tried everything, changing the “before_script:” and used the “variables: GIT_SUBMODULE_STRATEGY: … all of them” I tried everything else I found but all of them are speaking about docker and Linux but my runner is on windows.
I tried to change the submodule to ssh :
image
I need to add the private key but I couldn’t add it because all the given codes don’t run on the GitLab windows runner pls help.
I want to use this code but i dont know what is the equivalent of it on the windows runner.

before_script:

Install ssh-agent if not already installed, it is required by Docker.

(change apt-get to yum if you use an RPM-based image)

  • ‘which ssh-agent || ( apt-get update -y && apt-get install openssh-client -y )’

Run ssh-agent (inside the build environment)

  • eval $(ssh-agent -s)

Add the SSH key stored in SSH_PRIVATE_KEY variable to the agent store

We’re using tr to fix line endings which makes ed25519 keys work

without extra base64 encoding.

https://gitlab.com/gitlab-examples/ssh-private-key/issues/1#note_48526556

  • echo “$SSH_PRIVATE_KEY” | tr -d ‘\r’ | ssh-add -

Create the SSH directory and give it the right permissions

  • mkdir -p ~/.ssh
  • chmod 700 ~/.ssh

Optionally, if you will be using any Git commands, set the user name and

and email.

#- git config --global user.email “user@example.com
#- git config --global user.name “User name”

  • Runner (Hint: /admin/runners):

Or pls give another solutions or possibilities to try to get it working and Thank you so much all

Did you ever find a solution to this. The Gitlab docs on this are still only linux specific.

In case anyone else comes across this issue, the solution for me was to make my submodule paths relative per https://docs.gitlab.com/ee/ci/git_submodules.html. Turns out gitlab ci uses https not ssh…