Gitlab Container on Docker

Hello Everyone,

I am still noob at this, I got gitlab running in a docker container and I am able to see it is up and running (The Container) on port 8081

Here is the container status:
8303431c3a55 ulm0/gitlab “/assets/wrapper” 4 weeks ago Up 4 days (healthy)>22/tcp,>80/tcp,>443/tcp ohgl01

Here is the run line to deploy the container:
docker run -d --name ohgl01 --hostname ohgl01.cfs.loc -p 8443:443 -p 8081:80 -p 2222:22 --name ohgl01 -v /srv/gitlab/config:/etc/gitlab -v /srv/gitlab/logs:/var/log/gitlab -v /srv/gitlab/data:/var/opt/gitlab ulm0/gitlab

I am now trying to connect to it, to push an image to it. Does anyone know how to do that on a GitLab docker container? What is the syntax of the command used to push the image to it?

I have tried: git clone git@ohgl01.cfs.loc:8081/cfadmin/test01.git (This one asks for a password) & git clone git@ohgl01.cfs.loc:cfadmin/test01.git
neither of the above worked. The user associated is cfadmin and I am able to login with this user name with no problem via the web gui.

Thanks for your time and help,

Hi @mcooper59
to use HTTP you have to run git clone http://ohgl01.cfs.loc:8081/cfadmin/test01.git which will prompt you for username and password.
To use SSH you have to configure SSH keys. Since you have SSH on non-standard port, you also need to configure your ~/.ssh/config or use ssh://git@ohgl01.cfs.loc:2222/cfadmin/test01.git