GitLab http worked fine on reverse proxy, but not +SSL

So I followed the standard guide to get GitLab running on my Ubuntu16 server with reverse proxy Nginx. Worked fine.

###Now I want SSL. I followed this guide:

###I have the following uncommented in gitlab.rb:

external_url '' # substituted real site for
web_server['external_users'] = ['www-data'] # User for existing nginx
    nginx['enable'] = false # Disable because reverse proxy
    nginx['listen_port'] = 80 # Most reverse proxy traffic seems to be 80
    nginx['listen_https'] = false #false because of reverse proxy, right? I tried true, this is confusing

nginx['proxy_set_headers'] = {
  "X-Forawrded-Proto" => "https",
  "X-Forwarded-Ssl" => "on",

nginx['real_ip_trusted_addresses'] = ['', ''] #Not really sure if this is right?
nginx['real_ip_header'] = 'X-Real-IP'
nginx['real_ip_recursive'] = 'on'

I restart with gitlab-ctl reconfigure I believe the command was

I then used the following nginx .conf settings:

I replaced the two “YOUR_SERVER_FQDN” with my own. Replaced the certs with my own.

sudo nginx -t np works
sudo nginx service restart

Now nothing seems to work anymore. Any ideas?

1 Like