Gitlab Omnibus has lost all my projects, groups etc after an upgrade

Hi, in trying to upgrade from Gitlab Omnibus 8.12.13 to 9.5.8, Gitlab seems to have lost all my projects, groups etc. Furthermore, when I try to restore from the backup it created they are missing there too! During the upgrade, I ran into some issues with regard to postgres missing pg_trm or somesuch. I managed to get gitlab to start ok, but when I ran gitlab check it has a line saying “hooks directories in repos are links: … can’t check, you have no projects”. What I’m really worried about is that it also gives me that after rolling back and my gitlab install appears to be empty! It’s as if all the database content has disappeared.

Here is the info for the backup I just rolled back to:

gitlab-rake gitlab:env:info

System information
System: Ubuntu 16.04
Current User: lsds_git
Using RVM: no
Ruby Version: 2.3.1p112
Gem Version: 2.6.6
Bundler Version:1.13.6
Rake Version: 10.5.0
Sidekiq Version:4.1.4

GitLab information
Version: 8.12.13
Revision: 06c1f94
Directory: /opt/gitlab/embedded/service/gitlab-rails
DB Adapter: postgresql
SSH Clone URL:
Using LDAP: yes
Using Omniauth: no

GitLab Shell
Version: 3.6.1
Repository storage paths:

  • default: /vol/lsds/shared/lsds-new-gitlab/git-data/repositories
    Hooks: /opt/gitlab/embedded/service/gitlab-shell/hooks/
    Git: /opt/gitlab/embedded/bin/git

gitlab-rake gitlab:check

Checking GitLab Shell …

GitLab Shell version >= 3.6.1 ? … OK (3.6.1)
Repo base directory exists?
default… yes
Repo storage directories are symlinks?
default… no
Repo paths owned by lsds_git:lsds_git?
default… no
User id for lsds_git: 951. Groupd id for lsds_git: group lsds_git doesn’t exist
Try fixing it:
sudo chown -R lsds_git:lsds_git /vol/lsds/shared/lsds-new-gitlab/git-data/repositories
For more information see:
doc/install/ in section “GitLab Shell”
Please fix the error above and rerun the checks.
Repo paths access is drwxrws—?
default… yes
hooks directories in repos are links: … can’t check, you have no projects
Running /opt/gitlab/embedded/service/gitlab-shell/bin/check
Check GitLab API access: OK
Access to /home/lsds_git/.ssh/authorized_keys: OK
Send ping to redis server: OK
gitlab-shell self-check successful

Checking GitLab Shell … Finished

Checking Sidekiq …

Running? … yes
Number of Sidekiq processes … 1

Checking Sidekiq … Finished

Checking Reply by email …

Reply by email is disabled in config/gitlab.yml

Checking Reply by email … Finished

Checking LDAP …

Checking LDAP … Finished

Checking GitLab …

Git configured with autocrlf=input? … yes
Database config exists? … yes
All migrations up? … yes
Database contains orphaned GroupMembers? … no
GitLab config exists? … yes
GitLab config outdated? … no
Log directory writable? … yes
Tmp directory writable? … yes
Uploads directory setup correctly? … skipped (no tmp uploads folder yet)
Init script exists? … skipped (omnibus-gitlab has no init script)
Init script up-to-date? … skipped (omnibus-gitlab has no init script)
projects have namespace: … can’t check, you have no projects
Redis version >= 2.8.0? … yes
Ruby version >= 2.1.0 ? … yes (2.3.1)
Your git bin path is “/opt/gitlab/embedded/bin/git”
Git version >= 2.7.3 ? … yes (2.7.4)
Active users: 1

Checking GitLab … Finished

OK I managed to restore from a different backup so this can be ignored.