Gitlab package registry returning 404 when uploading package

Hi,

Several days ago our Gitlab package registry stopped working. We are unable to publish a new package and we are unable to install currently available packages. I presume the root cause is the same.

We are using gitlab.com (help says GitLab Enterprise Edition 13.11.0-pre), we are not using self-hosted Gitlab.

We had it up&running for several months without a problem. API on the Gitlab side was not changed (at least as far as I can see in the documentation), we haven’t changed the upload part of the pipeline and API tokens have not expired - I have no idea why did it stop to work all of a sudden.

I’ve tried manual upload and the same problem happens there also.

Publish part in CI looks like this:

build-package:
stage: publish
image: python:3.6
script:
  - cat $PYPIRC > /tmp/.pypirc
  - pip install twine
  - sed -i 's;version=.*,;version="'"${CI_COMMIT_TAG}"'",;' setup.py
  - python setup.py  bdist_wheel
  - python -m twine upload --repository p-text dist/* --config-file /tmp/.pypirc
only:
  - tags

Inside .pypirc we have configured repository for the relevant project, and the repo URL looks like this:

https://gitlab.com/api/v4/projects/<PROJECT_ID>/packages/pypi

Error that we see is following:

$ python -m twine upload --repository p-text dist/* --config-file /tmp/.pypirc
Uploading distributions to https://gitlab.com/api/v4/projects/<PROJECT_ID>/packages/pypi
Uploading p_text-0.1.4-py3-none-any.whl
100%|██████████| 35.6k/35.6k [00:00<00:00, 41.1kB/s]
NOTE: Try --verbose to see response content.
HTTPError: 404 Not Found from https://gitlab.com/api/v4/projects/<PROJECT_ID>/packages/pypi

For troubleshooting I’ve tried to perform this manually in order to test it, same happens.

Does anyone have an idea what could be the problem?

Thanks.

I created a new personal access token and everything works as before.
The old one has not expired, correct accesses are in place and I have no explanation why it does not work all of a sudden, but since I fixed it with a new token…I do not care much anymore.