Gitlab Runner: couldn't execute POST

I setup my own GitLab server a few days a go and everything is working as it should. Now I found out about GitLab runner and I wanna try deploying my application over that. Before descripting my problem I will quickly go over how my network works.

In the front I have my nginx proxy manager with redirects incoming traffic to the correct docker container the proxy then also applies a wild card certificate. I should also comment that the gitlab server and gitlab runner are not the same container but are in the same network.

On to the problem so the first weird thing is that as soon I create a runner in the gitlab admin panel it tries redirecting me to my domain and a port with actually shouldn’t happen. With results in a connection not secure popup.


I can bypass that by just removing the port and I get the expected result

Now to the gitlab runner as soon I try registering the gitlab runner with the command I received an error.

I have linked some modified commands that I tried with result in the same or a different error.

Https without Port:

Http without Port:

I found out that there is one option that actually works, but im not very happy with the result since firstly is uses https and I requires a port.

I look forward for some answers.


I have tried some stuff with the created runner and im now running into an other issue.
I think I might have messed something up with my current structure but can’t really tell what the issue is.

What’s your external_url in gitlab.rb?

version: '3.6'
    container_name: gitlab
    image: gitlab/gitlab-ce:latest
    restart: always
        external_url ''
        gitlab_rails['gitlab_shell_ssh_port'] = 2224
        nginx['listen_port'] = 8929
        nginx['listen_https'] = false
        postgresql['enable'] = false
        gitlab_rails['db_adapter'] = 'postgresql'
        gitlab_rails['db_encoding'] = 'utf8'
        gitlab_rails['db_host'] = 'postgres'
        gitlab_rails['db_port'] = '5432'
        gitlab_rails['db_username'] = 'gitlab'
        gitlab_rails['db_password'] = 'mysecurepassword'
      - 8929:8929
      - 2224:22
      - ./config:/etc/gitlab
      - ./logs:/var/log/gitlab
      - ./data:/var/opt/gitlab
    shm_size: 256m
    name: homelab-network
    external: true