Gitlab Runner does not work anymore

Hello everyone,

We have a Gitlab runner that worked well for the last month, but since this morning, it doesn’t seems to work anymore. When running the pipeline we get this output:

Running with gitlab-runner 11.9.0 (692ae235)
on net-runner dbJ-VftN
Using Shell executor…
ERROR: Job failed: exit status -1073741502

Our GitLab runner is use to compile and test a .net application. It is running on a Windows 10 PC and is configured like this:

concurrent = 1
check_interval = 0

session_timeout = 1800

name = “net-runner”
url = “
token = “xxxxxxxxxxxxxxxxx”
executor = “shell”
shell = “powershell”

We have tried several things so far, that didn’t work:

  1. Restarting the runner
  2. Create another runner with a new registration token
  3. Update GitLab-runner and GitLab to the newest version (11.9)

edit: We are able to run a single jobs when starting the runner in debug mode (GitLab-runner.exe --debug run). However, only one job at a time, as soon as we run the whole pipeline, only the first job works, the others have still the same error.

As the CI worked well for a month, I don’t think it is a configuration error. If you guys have any idea how I could solve this problem, I would be grateful!

Thanks in advance,


This might be a duplicate of Src refspec master does not match any

I’m having same issue on 12.5.0.
Did you get your problem resolved?

Running with gitlab-runner 12.5.0 (577f813d)
  on fms07wnutlab01 efc7b3ce
Using Shell executor...
ERROR: Job failed: exit status -1073741502


the exit status leads to some google results.

This would somehow indicate that some service dependencies failed -

Specifically to Powershell, it might be a problem with its console -

Which version of the GitLab runner and Windows is involved here?