Gitlab runner online but not picking up jobs, when debug : 503 Service Temporarily Unavailable

Hello everyone,

Im looking for some guidance for configuring gitlab-runner with docker executor on linux server hosted on Digital Ocean.

Ive followed steps from:

Managed to install gitlab-runner, register as shared runner, configured everything according to the
documentation. But it still didnt pick up any jobs.

Runner is online and showing within project under: Settings->CI/CD->Runners.

But when I type:
gitlab-runner --debug run it shows:

runner=dfgdgdzsgdsz status=503 Service Temporarily Unavailable

Ive also tried to add project specific runner - the same happens. Job is pending.
Gitlab-ci.yml looks like this:
image: alpine
- echo “Hello” > index.html

I’ve checked config.toml file, urls, run: gitlab-runner restart, verify and also downgraded version of
Gitlab runner to 15.1.1 to match with Gitlab version: 15.1.2.

Also checked connection with gitlab:

  • ping by running
  • connect to the api using curl?
    curl ""

And connection is successful.
Any ideas on that?

I have the same issue on my on-prem, after registering, my runners will post successfully to runners/verify but cannot post to request jobs.

I’m running gitlab on-prem using the docker image: gitlab/gitlab-ce:15.2.2-ce.0

The runners are using the docker image: gitlab/gitlab-runner:v15.2.1

Here’s an excerpt from gitlab’s log: - - [02/Aug/2022:09:05:46 +0000] "POST /api/v4/jobs/request HTTP/1.1" 503 190 "" "gitlab-runner 15.2.1 (15-2-stable; go1.17.9; linux/amd64)" - - - [02/Aug/2022:09:05:46 +0000] "POST /api/v4/runners/verify HTTP/1.1" 200 5 "" "gitlab-runner 15.2.1 (15-2-stable; go1.17.9; linux/amd64)" -

Seen from a runner with debug logging:

Trying to load /etc/gitlab-runner/certs/gitlab.******.crt ... 
Dialing: tcp gitlab.******:443 ...         
Registering runner... succeeded                     runner=GA8zXVfs
Runner registered successfully. Feel free to start it, but if it's running already the config should be automatically reloaded!


Trying to load /etc/gitlab-runner/certs/gitlab.******.crt ... 
Dialing: tcp gitlab.******:443 ...         
WARNING: Checking for jobs... failed                runner=iTTff2WP status=503 Service Unavailable
Feeding runners to channel                          builds=0

Hi !

THe rpoblem is solved. It was an issue on gitlab server side. In the configuration file there were following line in /etc/gitlab/gitlab.rb:
nginx[‘custom_gitlab_server_config’] = “location /api/v4/jobs/request {\n deny all;\n return 503;\n}\n”

After deleting it , all pipelines starts to run .
So while having connection issues gitlab runner <-----> server, its important to also check config files on server side.

1 Like