Gitlab-Runner Runners never connect while on a local GitLab instance

Describe your question in as much detail as possible:
I am having issues with my local instance of GitLab ee trying to understand the basics of CI/CD. I am attempting to use gitlab-runner and gitlab-ee in Docker to have everything self contained. My problem is that all of the runners I attempt to connect to my local GitLab instance never connect, and if they do, do not seem to function properly. Any pipeline that is started fails without a trace.

EDIT: Additionally, it should be noted that I am running this in a VirtualBox virtual machine running Ubuntu 20.04.2 with a Windows 10 host machine.

  • What are you seeing, and how does that differ from what you expect to see?
    I see my runners are registered on my admin section of GitLab but they all never connect and have a warning sign next to them saying they’ve never connected.

  • Consider including screenshots, error messages, and/or other helpful visuals

  • What version are you on? Are you using self-managed or

    • GitLab (Hint: /help): GitLab Enterprise Edition 13.11.4-ee
    • Runner (Hint: /admin/runners): 13.12.0
  • Add the CI configuration from .gitlab-ci.yml and other configuration if relevant (e.g. docker-compose.yml)

  image: 'gitlab/gitlab-ee:latest'
  restart: always
  hostname: ''
      external_url ''
      gitlab_rails['gitlab_shell_ssh_port'] = 2224
    - '8929:8929'
    - '2224:22'
    - '$GITLAB_HOME/config:/etc/gitlab'
    - '$GITLAB_HOME/logs:/var/log/gitlab'
    - '$GITLAB_HOME/data:/var/opt/gitlab'
  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?
    I’ve uninstalled and reinstalled gitlab-runner in docker, I’ve tried lower versions, tried upgrading those versions, tried uninstalling and completely reinstalling gitlab-ee. I am thoroughly confused and need some help.
    I’ve read the relevant parts from here, these threads, and here.

Thanks for taking the time to be thorough in your request, it really helps! :blush:

Nevermind! I seemingly had the simplest of issues that I really can’t believe I messed up. I guess when installing gitlab-ee and gitlab-runner I had never had a /var/lib/gitlab-runner folder made. My mistake. This thread can be closed!

1 Like