Gitlab web interface - download snapshot size is ZERO

I’ve been using gitlab (on Debian Jessie, currently gitlab-ce 8.7.0-ce.0) for about a year now and I’m very happy with it. A colleague of mine asked me to download some code of mine, so I gave him access to my gitlab. For the first time the function “Download zip”, which downloads a snapshot of the source code, was tried. We discovered that it gives a zip file with size that is exactly zero.

I tried other types, like tar.gz and tar, but these give a blank page and nothing happens.

Could someone tell me whether this is a bug or a problem on my end and assist me in resolving this? Please feel free to ask for any additional information you require.

I would like to add that I previously had a problem that cloning from my gitlab https would give empty repositories. I resolved this issue using these lines in /etc/gitlab/gitlab.rb:

nginx['enabled'] = false
gitlab_git_http_server['listen_network'] = "tcp"
gitlab_git_http_server['listen_addr'] = "localhost:8081"

It turned out that Gitlab was upgraded and uses a new reverse proxy server of its own, called “Gitlab-workhorse” since a while. I had to reconfigure my Apache webserver with a new virtual host script for the new reverse proxy. Also I had to modify the configuration of /etc/gitlab/gitlab.rb from:

nginx['enabled'] = false
gitlab_git_http_server['listen_network'] = "tcp"
gitlab_git_http_server['listen_addr'] = "localhost:8081"

to:

nginx['enable'] = false
web_server['external_users'] = ['www-data']
gitlab_workhorse['listen_network'] = "tcp"
gitlab_workhorse['listen_addr'] = "localhost:8181"
1 Like

Curious, do you have anything special setup in your apache.conf

Reason I ask is, that I have the same problem, but adding that code you suggested, didn¨t help me.

So I was curious about your setup in gitlab.rb and your apache.conf.

That’s all there is, unfortunately. Everything else is the default.