Group runner with shell executor

Hi, I am fighting to configure a group runner with shell executor. It is on the same server as the webserver.
I also tried with SSH runner and both scenarios take me to an error:

ERROR: Job failed: prepare environment: Process exited with status 1. Check for more information

Where to start from? I have tags properly set up. .yml was also tested with a shared runner.
I Have no idea what is wrong?!?

Hey there,

Can you maybe post your config.toml? Also on which OS is your Runner installed?

This normally happens when there is a problem in configuration (e.g. you use wrong shell command).

Hi, i found what the problem is.
one of the logs on the server showed the following:

WARNING: Job failed: prepare environment: exit status 1. Check Types of shells supported by GitLab Runner | GitLab for more information

So i followed the link and commented this part of .bash_logout and it worked.

if [ "$SHLVL" = 1 ]; then
    [ -x /usr/bin/clear_console ] && /usr/bin/clear_console -q
1 Like