Host key verification failing

Hello, I am trying to get the Gitlab’s CI/CD running using docker executor.
I want to use SSH - so I:

  • switched to gitlab-runner account on the target server (runner is already registered with the project)
  • generated SSH key pair and saved in ~/.ssh/ directory
  • added new CI/CD variable named SSH_PRIVATE_KEY - Value consists of private key, I did not check the box Protect variable
  • added new Deploy key in Repository Settings - name is SSH_PUBLIC_KEY and the content is public key from the pair generated few steps back
  • added before_script section inside .gitlab-ci.yml,as we use docker executor and followed documentation for adding private key from the environment variable: [](docs link)

I tried switching to gitlab-runner unix account and tried to clone the repository using cli, everything went fine.

However, when I run our repository pipeline, which uses yarn, I am experiencing following error:

Error: Command failed with exit code 128: git ls-remote --heads ssh://
Host key verification failed.
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I can not get past this error, any help is greatly appreciated:

Here are my gitlab-ci.yml and job output: gitlab-ci.yml; job output