How can I run in a .gitlab-ci.yml the following http processes?

I have a node web application that uses express serving some content, etc. I have another node application sending requests to the express app. So a client-server group of applications. I created a node script that launches the server and then launches the client and make some tests (get url, check response, etc). Everything fine. Then I created a .gitlab-ci.yml and tried to do the same thing. I installs fine with npm install but when I launch the same node script the following problem appears. What is wrong with this? Is there some missing configuration for ci in gitlab? Thank you

npm info lifecycle ng2-websockets-server@1.0.0~pretest: ng2-websockets-server@1.0.0

ng2-websockets-server@1.0.0 test /builds/wps-nl/parking-station-emu
node ./tests/launch_tests.js

npm info lifecycle ng2-websockets-server@1.0.0~test: ng2-websockets-server@1.0.0
stderr: events.js:163
throw er; // Unhandled ‘error’ event

Error: connect ECONNREFUSED
at Object.exports._errnoException (util.js:1034:11)
at exports._exceptionWithHostPort (util.js:1057:20)
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1099:14)

child process exited with code 1
server process exited with code null
npm info lifecycle ng2-websockets-server@1.0.0~posttest: ng2-websockets-server@1.0.0
npm info ok