How to upgrade from 13.12.5 to 14.0.0

Hello.

I’m having trouble upgrading to Gitlab Version 14.
I have been using Gitlab omnibus on Ubuntu since before version 12.

It was showing update abailable, so it will show up as the latest version when I run the update.

image1

I tried to update it as follows.
apt-get install gitalb-ce.

The following message is displayed as the latest.

gitlab-ce is already the newest version (13.12.5-ce.0).

I tried to update it by reconfigure, referring to the article about changing from unicorn to Puma, but there was no change.
Puma | GitLab 1.

  1. add puma['enable'] = true to /etc/gitlab.rb. 2.
    1. run sudo gitlab-ctl reconfigure.
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial

Please reply if you know the solution.

GitLab 14 is not released for xenial. Upstream support for xenial ended in April, and 13.12 (the .0 version released 22 May) was the last GitLab version released for xenial, and they have mentioned that under “Deprecations” in several (I think) of the past release announcements.

You should get yourself on a newer Ubuntu version.

1 Like

Thanks for the reply.

I will update my OS and then update GitLab again.

I updated Ubuntu and updated Gitlab again, but still couldn’t do it.

What other possible causes could there be?

ubuntu@ip-192-168-0-227:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal
ubuntu@ip-192-168-0-227:~$ sudo apt-get install gitlab-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gitlab-ce is already the newest version (13.12.5-ce.0).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I had this once with Debian, when attempting to go from 12.9.3. What I had to do was refresh the repo:

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash

after this, try doing the usual upgrade:

apt upgrade

it should then pick up the new version. Yours will be slightly different, since the repo is for Ubuntu 18.04, but now you need to get the Ubuntu 20.04 one, so this should help.

Alternatively, you may need to go into /etc/apt/sources.list.d and remove the existing gitlab.list file and then run the curl command above. But only try this, if it fails from what I posted above.

1 Like

Thanks for the reply.

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash

I am using the gitlab-ce package.
I ran the following and the process is working.

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash.

It is not complete yet, but I will try to let you know the result.

Yes, change ce if not using ee. Hopefully it helps.

1 Like

I was able to update successfully.
Thanks to @iwalker and @grove for their help.
Very quick reply and solved the problem right away.
Thank you very much.

1 Like