I can't push to my repo on port 22


I’m facing an issue pushing my code to the repo for some time now and this is the error I’m receiving

ssh: connect to host gitlab.com port 22: Network is unreachable
fatal: Could not read from remote repository.

which it was working fine yesterday and I faced the same issue last Thursday but it start working after some time without me doing anything

I tried different ISPs and it give the same error.

Port 22 is working on Github, so I believe the issue on GitLab only

Any help is highly appreciated


ian@elise:~$ ssh -T git@gitlab.com
Welcome to GitLab, @iwalker!

possibly your IP address is the issue or a temporary routing problem since it’s working for me. Try running a VPN to change your IP/location and see if you can do it then. Either that, or try from home/work depending on wherever you are when the problem occurs.

Sounds similar to

where the OP proved very unwilling to believe the problem was on his end, but there still are a few good remarks.